Symptoms

When you attempt to activate a license you receive one or more of the following error messages:

Unable to activate the license. (505)


This license could not be activated. (2006)


Cause

This is caused when the License Manager is able to write to it's license file(s). This usually happens

on Windows Vista machines when the license was initially created while the application was running

"as an Administrator".


When files are created by an application that was run "as an Administrator" they are marked with a

security privilege so that only other users or applications running "as a Administrator" can access

them. If an application is run normally it runs with a lower security setting and Windows Vista will

prevent access.


Resolution

Run the license reset utility as an administrator and reset the required licenses. Then run the

software normally, enter the CD Key and then activate the software.


To reset your license

  1. Close all Solatech applications
  2. Click Start, Programs, Solatech, Solatech Window Covering Software 4, Utilities, Reset my software license.
  3. Contact Solatech for a reset code.
  4. Enter the code.
  5. Select the license to reset.
  6. Click OK.
  7. If needed, repeat steps 2 to 6 for Product Designer 4 and/or Solatech Report Writer 1.1.


Once the license has been reset you can run the application normally, enter the CD Key and then

activate the license.


Status

This behavior is by design.


Applies To:

  • Product Designer 4.2
  • Solatech Report Writer 1.1
  • Solatech Window Covering Software 4.2