Symptoms
When any of the applications or utilities listed at the bottom of this article attempt to communicate
with Solatech over the Internet the 'Testing Communications' dialog box appears but does not go
away.
Cause
The cause of this issue is unknown.
Workaround
To work around this issue you can set a switch in the Windows Registry that will indicate that the
communication testing has already been completed.
WARNING: Using Registry Editor incorrectly can cause serious, system-wide problems that may
require you to reinstall Windows to correct them. Solatech cannot guarantee that any problems
resulting from the use of Registry Editor can be solved. Use this tool at your own risk.
- Click Start, Run.
- Type 'regedit' and click OK.
- Navigate to the following key: HKEY_CURRENT_USER\Software\Solatech\Communications.
- Double-click on the name Passive.
- Change the value to 1 and click OK.
- From the Edit menu, click New, String Value.
- Enter the name 'TestRun' and press Enter.
- Double-click on the name 'TestRun'
- Change the value to 1 and click OK.
- Close the Registry Editor.
Status
Solatech has confirmed this to be a problem with the software listed at the end of this article. As
more information becomes available this article will be updated.
More Information
The first time that your Solatech software attempts to communicate with Solatech over the Internet
it runs a test to see the what type of configuration it should use when establishing a connection.
Under certain circumstances the testing process will hang. Since it's only trying to establish if it
should use passive mode or not, and under most network configurations passive mode is required,
you can manually enable passive mode and skip the test.
Applies To:
- Product Designer 4.0
- Product Designer 4.1
- Product Designer 4.2
- Solatech Report Writer 1.0
- Solatech Report Writer 1.1
- Solatech Update 4.x
- Solatech Window Covering Software 4.0
- Solatech Window Covering Software 4.1
- Solatech Window Covering Software 4.2