Symptoms

When you select one or more process reports to print and then click the Preview or Print button, the

screen flashes and returns to the print selection dialog box; nothing prints/previews.


Cause

This can be caused if the printer that is assigned to the printer configurations (Process Reports) is

not valid. For example if a printer has been changed in Windows.


Resolution

Update the printer configurations to reference the correct printer.

  1. Run SWCS.
  2. From the File menu, click Printer Configurations.
  3. Select the printer configuration (Process Reports).
  4. Click the down arrow on the Assigned Printer column.
  5. Select a valid printer from the list.
  6. Click Close.


Status

This behavior is by design.


More Information

If a valid printer cannot be found then the system cannot create the reports because it needs

information from the printer to calculate page size, margins, etc.


If you look in the event log you may also see messages indicating a report won't print because the

width is too small.


Applies To:

  • Solatech Window Covering Software 4.2